Chapitre 5

L'Organisation des Projets

 

 

1 – Les Opérateurs

 

2 – Le Projet

 

3 - Les Documents

 

4 - Le Calepin

 

Retour au sommaire principal

 

Retour au sommaire principal

 


1 - LeS OPERATEURS

3D Turbo est utilisé par des Opérateurs. Il est de la responsabilité du gestionnaire des projets de constituer la liste des opérateurs habilités.

 

Au lancement de 3D Turbo, le dialogue de Gestion des Opérateurs est présenté.

 

Ce dialogue a 2 fonctions :

 

1)     Constituer et gérer la liste des opérateurs habilités ą travailler sur le poste,

 

2)     Sélectionner l’Opérateur qui va intervenir dans la session de travail qui s’ouvre.

 

Pendant une session de travail , il est possible de changer d’opérateur.

 

Ce dialogue peut aussi źtre ouvert ą partir du Menu « 3D Turbo X / Opérateurs.. »

 

 

 

Au premier lancement de 3D Turbo, et tant que le liste n’aura pas été constituée ou modifiée, le nom de session est proposé.

 

 

 

 

 

Liste des Opérateurs#

 

 

1 – Constituer et Gérer le liste des Opérateurs

 

 

 

Seul un Gestionnaire de Projet habilité peut constituer et gérer la liste des Opérateurs.

Pour źtre habilité, il faut connaĒtre le mot de passe d’habilitation. Ce mot de passe est fourni par Soft’X lors de la délivrance de la licence. Pour garantir sa confidentialité, le mot de passe  ne peut źtre modifié qu’avec l’aide du support technique de Soft’X .

 

Pour modifier la liste des Opérateurs, entrer le mot de passe dans le champ prévu ą cet effet. Si le mot de passe est correct, on peut cliquer sur le Cadenas pour le déverrouiller . Les boutons  deviennent alors actifs.

 

 
Ajouter un Opérateur

Pour ajouter un Opérateur, cliquer sur le bouton  .

 

Un Opérateur nommé « Anonyme » est ajouté ą la liste.

 

Modifier le nom d’un Opérateur

 

Pour modifier le nom d’un Opérateur :

 

Double cliquer sur le nom de l’Opérateur ą modifier.

Le nom devient éditable.

 

Terminer la modification avec la touche Entrée ()

 

Retirer un Opérateur

 

Pour retirer un Opérateur, cliquer sur le bouton  .

 

 

 

 

 

Sélectionner l’Opérateur#

 

 

1 – Sélectionner l’Opérateur actif

 

 

 

Pour sélectionner l’Opérateur actif :

 

Ouvrir le dialogue de Gestion des Opérateurs,

 

Sélectionner le nom de l’Opérateur dans la liste,

 

Cliquer sur le bouton .

 

 

2 - Le Projet

Un projet est une unité de travail ą l'intérieur de laquelle se traitent les opérations de modélisation et de dessin.

 

Un projet doit źtre conću de telle maniŹre qu'il puisse źtre aisément consulté, dupliqué, sauvegardé et archivé.

 

Un projet se concrétise par un certain nombre de fichiers sur disque appelés Documents.

 

Les Projets et leurs Documents peuvent źtre gérés manuellement ou ą l’aide des fonctions de Services des Projets. Pour ouvrir le dialogue de Services des Projets, choisir la rubrique du menu « Fichier / Nouveau… » ou « Fichier / Ouvrir > Un Document… ».

 

 

 

 

 

 

 

Créer un nouveau Projet#

 

 

1 – Créer un Projet

 

 

 

Pour créer un nouveau Projet,  ouvrir les Services des Projets.

 

Ce panneau a 3 fonctions :

 

1)     Affiche le nom et la location du Document Sélectionné dans la liste des Documents récents,

2)     Permet d’entre le nom d’un nouveau Projet et de créer son dossier et son Document initial,

 

3)     Choisir un opérateur pour le Projet.

 

Pour créer un nouveau Projet :

 

-       Choisir un Opérateur ą l’aide du bouton « Opérateur »,

 

-       Entrer le nom du projet  dans le champ éditable,

 

-       Cliquer sur le bouton « Nouveau Projet »

 

 

 

Dans le dialogue systŹme, indiquer le Dossier qui devra contenir le projet.

 

Un dossier de Projet est créé ą cet emplacement et un Document Principal .3dxx est automatiquement créé et ouvert.

Les dossiers T3D_CompanionDocs  et VERSIONS sont également créés.

L’opérateur est prźt ą travailler sur ce nouveau projet

 

 

3 - Les Documents

Le nombre et le rangement de ces documents sur les disques sont laissés ą l'entiŹre appréciation de l'opérateur, qui choisira un découpage de son projet selon des critŹres pertinents.

 

Il est néanmoins recommandé d'utiliser le systŹme de création de Projet proposé par les «  Services des Projets ». Des dossiers standardisés sont alors créés sur disque pour structurer le nouveau projet.

 

Le Document Principal

Le Document Principal est l'unité de travail de base. 3D Turbo ne travaille que sur un seul document ą la fois. Cependant Il est possible :

 

-       d'ouvrir simultanément deux ou plusieurs copies du logiciel dans la mźme machine et ainsi d'ouvrir plusieurs documents

 

-       de fusionner tout ou partie d'un document résidant sur disque avec le document ouvert par 3D Turbo

 

-       de travailler en réseau, les documents du projet étant répartis entre les divers opérateurs de chaque poste du réseau. Un Chef de Projet doit alors źtre chargé de la consolidation et de la gestion des documents. Un mécanisme de verrouillage de calques permet ą chaque poste de consulter et d'utiliser, mais pas de modifier certains calques dans un ou des documents servant de fonds de projet partagés. Le Chef de Projet est responsable de la constitution et de la consolidation des fonds de projet.

 

Le contenu d'un document n'est limité que par la taille mémoire de la machine.

 

Le Dossier Companion

Un Projet est constitué d’un Document Principal rassemblant les éléments du projet (.3dxx, .3dzz), mais peut également dépendre de documents externes (images, photos, Pdf, Robots ). Ces documents externes, indispensables au fonctionnement du Projet (et ą ses divers affichages, Mises en Page,..) sont rassemblés dans un Dossier compagnon nommé « T3D_CompanionDocs ». Si le Document Principal doit źtre déplacé, archivé, ou transmis, son Dossier Compagnon doit l’ źtre également pour conserver l’intégrité du projet. En bref, le Dossier Companion doit toujours suivre le Document Principal.

 

Les Sous-Dossiers du Dossier Companion

Ces sous-dossiers sont créés automatiquement et systématiquement utilisés. La multiplicité et la quantité des composantes externes d’un projet (Robots, images, pdf,  prévisualisations, exports images, versions) impliquent une organisation plus structurante qui évite le vrac de documents dans le dossier Compagnon et accélŹre les recherches et les affichages .

Bien qu’ils ne soient pas obligatoires, il est fortement conseillé de les utiliser quand on intervient manuellement dans le Compagnon.

 

Le Dossier Versions

A tout moment,  une Version du Projet peut źtre créée. Les Versions sont  rangées dans un dossier « VERSIONS» situé au mźme niveau que le Dossier Compagnon.

 

 

NOTE SUR LA SECURITE

IMPORTANT: Les données d'un projet représentent un investissement important.

Nous ne saurions trop insister sur la nécessité de procéder ą des sauvegardes réguliŹres des documents d'un projet. En effet, l'alimentation électrique, les machines et les logiciels ne sont pas exempts de défauts ou d’aléas. En cas de problŹme, il est possible que certains fichiers deviennent illisibles ou disparaissent. S'il n'existe aucune sauvegarde de ces fichiers, ce peut źtre la perte de nombreuses heures de travail avec des conséquences économiques parfois douloureuses.

 

Nous préconisons la technique des sauvegardes tournantes. Chaque sauvegarde sera effectuée sur un média différent. Les media seront permutés ą chaque sauvegarde. On aura ainsi préservé les versions N, N-1, N-2, etc. selon le nombre de supports utilisés.

 

Il est en outre recommandé de stocker les media de sauvegarde en des lieux différents pour se prémunir contre les vols, incendies, et autres catastrophes possibles.

 

Par ailleurs 3D Turbo est doté d’un mécanisme de sauvergarde automatique périodique qui permet de régler les conditions de sécurité jugées adéquates pour le projet. Voir le Chapitre 11 – Les Réglages de 3D Turbo §2 – 3 Sauvegarde automatique

 

 

 

 

 

 

 

Enregistrer le document#

 

1 - Enregistrer le document

 

 

 

Pour enregistrer le document dans le mźme fichier que celui ą partir duquel il a été chargé :

 

Utiliser le menu Fichier/Enregistrer. (ou son équivalent – Clavier)

ou

Cliquer dans l'icône  .

 

Si le document est un nouveau document, choisir le nom du fichier et confirmer l'enregistrement.

 

Si le document est vide (ne contient aucune géométrie), il est quand mźme possible de l'enregistrer. Dans ce cas, seules les palettes, les points de vue, etc. sont enregistrés dans le fichier.

 

Remarque : Cette opération peut s'avérer dangereuse. Utiliser plutôt la méthode des sauvegardes tournantes exposée ci-dessus, avec l'aide de la fonction Fichier/Enregistrer Sous…  ou la systŹme des Versions.

 

 

 

 

 

Enregistrer Version#

 

 

2 - Enregistrer Version

 

 

 

Pour enregistrer une Version du document dans son état actuel :

 

Utiliser le menu Fichier/Enregistrer Version. (ou son équivalent – Clavier)

 

Le Document est enregistré dans le dossier « VERSIONS » du projet, sous un nom  indéxé par la date et l’heure ( ex : MANDUEL MASTER V4 (11/10/16 00.48.49).3dxv), avec une extension .3dxv ou .3dyv.

 

Utiliser le volet « Document » du Calepin pour renseigner sur les particularités de la version, préalablement ą son enregistrement. Lors de sa ré-ouverture, on disposera ainsi des informations pertinentes sur le contenu de la version.

Utiliser également la Capture de Prévisualisation pour différentier visuellement les versions.

 

Ces documents de version ne doivent pas źtre renommés. Ils sont gérés automatiquement par les Services de Projets. Ce sont néanmoins des Documents normaux.

 

 

 

 

 

Enregistrer une Copie...#

 

 

3 - Enregistrer une Copie

 

 

 

Pour enregistrer une Copie du document dans son état actuel :

 

Utiliser le menu Fichier/Enregistrer Copie. (ou son équivalent - Clavier)

 

Choisir le nom du fichier copie et confirmer l'enregistrement.

 

La Copie est enregistrée dans le dossier désigné, mais 3D Turbo continue de fonctionner sur le Document courant. Cette fonction fige donc un état du projet en cours.

 

Pour continuer ą travailler avec un document dupliqué, utiliser la fonction « Enregistrer Sous »

 

 

 

 

 

Enregistrer Sous...#

 

4 - Enregistrer Sous…

 

 

 

Pour enregistrer le document dans un fichier différent de celui ą partir duquel il a été chargé :

 

Utiliser le menu Fichier/Enregistrer sous…(ou son équivalent - Clavier)

ou

Cliquer dans l'icône avec le bouton droit ou la touche Ctrl ou Alt

 

Choisir le nom du fichier et confirmer l'enregistrement.

 

Si le document est vide (ne contient aucune géométrie), il est quand mźme possible de l'enregistrer. Dans ce cas, seules les palettes, les points de vues, etc sont enregistrés dans le fichier.

 

Sur Macintosh OsX :

 

En cochant la case 4__#$!@%!#__Pasted Graphic  du dialogue « Enregistrer Sous… », une image de prévisualisation est enregistrée dans le document. La taille de cette image égale la taille de la fenźtre de travail. Elle peut alourdir le document. Pour éliminer l'image de prévisualisation d'un document, enregistrer-sous le document sur lui mźme aprŹs avoir décoché la case "Avec Prévisualisation".

 

En cochant la case  du dialogue « Enregistrer Sous …», des informations indispensables pour la conversion DWG sont ajoutées au document. Cocher cette case si le document doit źtre converti par le logiciel DataTransporter.

 

En cochant la case du dialogue « Enregistrer Sous …»,les images référencées dans le document sont collectées automatiquement dans le dossier compagnon associée au document.

Prévisualisation

A partir de la version 10.5 Leopard de MacOSX, le systŹme est doté de nouvelles fonctions de Prévisualisation du contenu des documents. Pour s’adapter ą ces fonctionnalités, 3D Turbo est doté d’outils pour créer une image de Prévisualisation.

A tout moment dans le cours d’un projet,  il est possible de créer une image de Prévisualisation.

 

Créer une image de Prévisualisation

 

Pour créer une image de Prévisualisation :

 

- Afficher une vue dans 3D Turbo. Faire en sorte que cette image soit  la plus représentative possible du contenu du document. Réduire la taille de la fenźtre autour de 640x480 pour éviter de pénaliser la taille du document.

 

- Afficher le menu Contextuel de Visualisation de la fenźtre de travail et choisir la rubrique 

ou

 

- Dérouler le menu Fichier et choisir la rubrique  

 

L’image capturée reste en attente d’utilisation dans un Enregistrer-sous.

 

Enregistrer une image de Prévisualisation

 

 

Pour utiliser une image de Prévisualisation dans un document, faire un Enregistrer-sous et cocher la case « Avec Prévisualisation ».

 

Si une image a été capturée au préalable, elle apparaĒt dans le petit cadre.

 

Si aucune image n’a encore été capturée, la vue courante est affichée.

 

Pour forcer la vue courante comme image de Prévisualisation, cliquer sur  le bouton 

 

Pour forcer l’icône standard du type de document  ą la place de l’image, cliquer sur le bouton

 

 

Supprimer l’image de Prévisualisation d’un Document

 

Pour supprimer limage de Prévisualisation d’un document, faire un Enregistrer-sous en décochant la  case de Prévisualisation.

 

Prévisualiser un document dans le Finder de Mac OsX

 

Pour prévisualiser l’image d’un document, il faut installer le Plug-In TurboFilePreview.qlgenerator, fourni avec 3DTurbo, dans le dossier BibliothŹque/QuickLook du disque de démarrage ou du systŹme.

 

 

 

 

 

Ouvrir un document#

 

5 - Ouvrir un Document

 

 

 

Pour ouvrir un Document :

 

Utiliser le menu Fichier/Ouvir >  Un Document…(ou son équivalent - Clavier)

ou

Cliquer dans l'icône .

 

Les Services des Projets sont proposés :

 

 

4 possibilités d’ouvertures sont possibles

 

1)     Ouvrir un Document récent ą partir de la liste des Documents récents

2)     Créer un nouveau Document vide ( Hors gestion de Projet )

3)     Ouvrir une Version d’un Document récent

4)     Ouvrir un Autre Document ( Hors gestion de Projet )

 

Ouvrir un Document récent

Choisir le Document dans la liste et cliquer le bouton « Ouvrir ».

ou

Double cliquer sur le nom dans la liste .

 

Pendant la phase d’ouverture du Document, le message suivant est affiché :

 

 

Créer un Document vide

Cliquer le bouton « Nouveau Document».

 

Ouvrir une Version

Si le Document sélectionné dans la liste des Documens récents ą des Versions enregistrées, elles apparaissent dans le tableau des Versions.

 

 

 

Sélectionner une Version dans la liste  et cliquer le bouton « Nouveau Document».

ou

Double cliquer sur le nom dans la liste.

 

Ouvrir un Autre Document

Pour ouvrir un document quelconque, en dehors de la Gestion de Projet :

 

Cliquer le bouton « Ouvrir Autre Document».

 

Choisir le filtrage dans la liste des filtres du dialogue de choix du type de document ą ouvrir. Voir le chapitre "Import-Export" pour connaĒtre les types de documents que 3D Turbo peut lire.

 

Sur Macintosh OsX :

 

Si le document avait été enregistré avec prévisualisation, et si le navigateur est en mode QuickLook , l’image de prévisualisation est affichée dans la zone de QuickLook, sinon c’est l’icône du document qui d’affiche :

 

 

 

 

 

 

 

Ouvrir un document utilisé récemment#

 

6 - Ouvrir un Document utilisé récemment

 

 

 

3D Turbo mémorise les noms et emplacements sur disque des 50 derniers documents ouverts.

 

Pour ouvrir un document utilisé récemment :

 

Utiliser les Services d’Ouverture des Documents

ou

Utiliser le menu Fichier/Ouvir > ...Nom d'un Document…

ou

Cliquer dans l'icône avec le bouton droit ou la touche Ctrl ou Alt

 

Choisir un document dans la liste figurant dans la partie basse du menu.

 

 

 

 

 

 

 

 Version précédente#

 

 

7 – Ouverture rapide d’un Document

 

 

 

 

Pour ouvrir rapidement un document sans passer par les Menus d’ouverture, il suffit de faire Glisser/Déposer un Document 3D Turbo repéré dans un fenźtre du Finder, ou une icône de documet se trouvant sur le Bureau du Mac, directement dans la fenźtre de travail. Si le projetest vide, ie document deviengt le projet courant.

Si un projet est déją ouvert, la foncgtion de Fusion  est proposée.

 

 

 

 

 

 

 

 

 

 Version précédente#

 

 

8 - Version Précédente

 

 

 

Pour abandonner les modifications apportées ą un document lors d'une session de travail et revenir ą la version du document derniŹrement enregistrée par la fonction « Enregistrer » dans le fichier disque (Document Principal)  :

 

Utiliser le menu Fichier/Version Précédente. (ou son équivalent - Clavier)

 

Le dialogue ci-dessous est présenté pour donner une chance ą l'opérateur d'enregistrer l'état courant de son document avant de revenir ą la version précédente.

 

 

 

 

 

 

 

Nouveau document#

 

9 - Nouveau Document

 

 

 

Pour abandonner le document courant et créer un document vide :

 

Utiliser les Services d’Ouverture des Documents

ou

Utiliser le menu Fichier/Nouveau. (ou son équivalent - Clavier)

ou

Cliquer dans l'icône .

ou

Cliquer  dans le bouton  de la barre de la fenźtre de travail.

 

Le dialogue ci-dessous est présenté pour donner une chance ą l'opérateur d'enregistrer l'état courant de son document avant de l'évacuer.

 

 

 

 

 

 

 

 Fusionner#

 

 

10 - Fusionner un Document

 

 

 

Pour fusionner dans le document actuel tout ou partie d'un document résidant sur disque, procéder comme suit :

 

Utiliser le menu Fichier/Fusionner ou l’icône et choisir le fichier ą fusionner.

 

Le dialogue de fusion est présenté  - Choisir l’onglet « Calques ».

L’onglet « Mises en Pages » permet de fusionner les Mises en Page. Voir ici.

L’onglet Blocs permet de fusionner les Blocs. Voir ici.

 

 

Sélectionner le ou les calques ą fusionner

 

Le panneau Calques source présente la liste des calques détectés dans le document ą fusionner. Naviguer dans ce panneau ą l’aide des outils habituels (FlŹches du clavier, …) Sélectionner dans ce panneau le ou les calques ą fusionner. La zone d’affichage présente le contenu du dernier calque sélectionné .

 

Pour ajouter un calque ą la sélection, cliquer avec la touche Maj

Pour ajouter/retirer un calque de la sélection, cliquer avec la touche  Cmd (  ). Cliquer/Glisser avec l’une ou l’autre touche pour ajouter/retirer une plage de calques

 

Sélectionner un groupe de calques

 

Le menu situé sous la liste permet de sélectionner un groupe de calques.

 

En choisissant « Tous » , on sélectionne tous les calques.

 

La suite du menu montre les groupes de calques détectés dans le document. En choisissant un de ces groupes, on sélectionne les calques qu’il contient. Les groupes de calques sont aussi appelés « Combinaisons de Calques » ou « Piles de Calques »

 

 

Régler les options de fusion.

 

Le panneau Destination présente les options possibles :

 

-       Dans les calques libres :

 

              En cochant cette option, on force le chargement des calques sélectionnés dans les calques libres du projet en cours, ą partir du n° de calque indiqué. En décochant cette option, les calques sélectionnés sont chargés dans les mźmes numéros de calque, en addition ą ce qui s’y trouve éventuellement déją.

 

-       Convertir :

 

              En cochant cette option, on force la conversion des coordonnées des entités fusionnées dans l’unité du modŹle en cours.

              En décochant cette option, les entités sont fusionnées sans conversion.

 

Cliquer Fusionner pour charger les calques sélectionnés dans le modŹle en cours selon les options choisies. Un contrôle du document et les réparations éventuellement nécessaires sont réalisés pendant la fusion.

 

 

 

 

 

 Fusionner un document#

 

 

11 - Examiner un Document sur disque

 

 

 

Pour examiner le contenu d’un document résidant sur disque, procéder comme suit :

 

Utiliser le menu Fichier/Fusionner ou l’icône et choisir le fichier ą examiner. Le dialogue de fusion est présenté. (Cf. ci-dessus)

 

Sélectionner un calque dans la liste des calques.

 

 

Son nom est son origine sont affichés

 

 

 

 

 

La zone de visualisation montre le contenu du calque dans le dernier point de vue utilisé dans le document.

 

 

 

 

Les outils de visualisation permettent d’examiner le contenu du calque sélectionné.

 

Vue de Dessus

Vue de Face

Vue de Côté

Vue Perspective automatique

Vue en Filaire

Vue en Faces Cachées

Changer le point de vue par mouvements de la caméra en mode panoramique. Cliquer sur la direction voulue.

 

Cliquer Annuler pour arrźter l’examen ou Fusionner pour charger les calques sélectionnés.

 

 

 

 

 

Quitter#

 

 

12 – Chargement d’un calque sur disque

 

 

 

Procéder comme pour examiner un document sur disque ou fusionner un document.

 

Positionner le curseur dans la zone de dessin. Le curseur devient  .

 

Cliquer et glisser l’image translucente vers :

           

-       La fenźtre de travail. LČcher le bouton de la souris dans la fenźtre de travail. Le contenu du calque est accroché ą la souris. Cliquer pour l‘insérer dans le calque courant.

-       La fenźtre des calques. LČcher le bouton dans la fenźtre des calques. Un Objet de Bureau de type géométrique est instantanément créé avec tout le contenu du calque.

-       Le bureau du Finder ou une fenźtre ouverte sur le bureau. LČcher le bouton de la souris ą cet endroit. Un fichier CLIPPING est créé.

 

 

 

 

 

 Collecter les images#

 

 

13 – Collecter les images du Document

 

 

 

Les images utilisées dans un document (Cotes image, Mises en Page, Textures,…) doivent pouvoir źtre localisées aisément par 3D Turbo. D’autre part, un document étant destiné ą circuler, il est important que les images qu’il contient puissent źtre aisément transmises avec lui. Les images pouvant provenir de nombreuses sources, 3D  Turbo offre une fonction permettant de rassembler ces images en un mźme lieu.

 

Il y a 2 maniŹres de collecter les images utilisées dans un document :

 

1) Par la fonction du menu Fichier/Collecter les images 

 

Elle rassemble les images dans un unique dossier nommé « T3D_CompanionDocs» situé dans le mźme dossier que le document en cours.

 

Les images collectées sont soit des copies, soit des alias des images originales.

Le dialogue ci-contre permet de choisir comment les images sont rassemblées.

Si le document doit źtre transmit ą des tiers, il est recommandé de choisir le mode Recopie.

 

Le dossier T3D_CompanionDocs doit toujours accompagner le document.

 

 

2) Par la fonction du menu Fichier/Enregister sous

 

 

Le dialogue d’enregistrement présente l’option

 

 

En cochant cette  option, le dossier compagnon T3D_CompanionDocs est créé (s’il ne l’est pas déją) et les images utilisées dans le document y sont recopiées.

 

 

 

14 – Collection Automatique des images

 

Par sécurité,et pour conserver l’intégrité du Projet, 3D Turbo collecte automatiquement  les images dans le sous-dossier « IMAGES » du dossier Companion, lors de l’ouverture d‘un document.

 

Comment 3D Turbo retrouve les images utilisées dans un document

3D Turbo retrouve les images de la maniŹre suivante :

 

-       il explore d’abord la Collection courante. Si l’image y est trouvée, il l’utilise; sinon…

-       il cherche le fichier image dont la référence disque est mémorisée avec l’image. S’il la trouve, il ajoute l’image ą la Collection et l’utilise; sinon…

 

Si le document en cours a déją été enregistré sur disque,

 

-       il cherche le fichier image dans le mźme dossier que le document en cours. S’il la trouve, il ajoute l’image ą la Collection et l’utilise; sinon…

-       il cherche le fichier image dans le dossier T3D_CompanionDocs. S’il la trouve, il ajoute l’image ą la Collection et l’utilise ; sinon il déclare l’image perdue. Fin de la recherche.

-        

Si le document en cours est nouveau (n’a pas encore été enregistré) il  demande ą l’opérateur oĚ se trouve l’image :

 

 

 

Si l’opérateur répond OUI, 3D Turbo présente le navigateur pour localiser l’image.

 

 

Si l’opérateur répond NON, ou si l’opérateur abandonne la recherche de l’image, 3D Turbo marque l’image comme perdue :

 

 

 

 

 

Réorganiser#              

 

 

15 – Réorganiser un Projet

 

 

 

Les grands projets traités avec 3D Turbo sont organisés autour de la structuration des calques. Habituellement, on planifie une organisation des Calques sur laquelle toute l’architecture du Projet sera bČtie.

 

Voici un exemple simplifié de planification d’un bČtiment ą 3 niveaux, par tanches de 20 calques :

 

 

et sa réalisation avec les calques dans 3D Turbo :

 

 

Mais un projet évolue et sa structure interne doit donc aussi pouvoir évoluer.

Cette fonction permet de réorganiser les calques d’un projet existant.

Le projet ą réorganiser soit résider dans un fichier de projet .3dxx. La réorganisation s’opŹre ą partir du fichier du projet.

 

Pour réorganiser les Calques d’un Projet :

 

Quitter tout travail en cours  (menu Fichier/Nouveaux) et préparer un Nouveau Document  vierge.

 

Choisir le rubrique « Réorganiser … » dans le menu Fichier et choisir le fichier du projet ą réorganiser

 

 

Ou

 

Choisir un projet dans le dialogue de Service des Projets et cliquer sur le bouton  

 

 

3D Turbo apprend les éléments du projet et  présente le dialogue de réorganisation des Calques :

 

 

Le principe s’apparente ą la Fusion,  avec un dialogue similaire fonctionnant en boucle.

 

Sélectionner le ou les calques ą insérer

 

Le panneau Calques présente la liste des calques détectés dans le document ą réorganiser. Naviguer dans ce panneau ą l’aide des outils habituels (FlŹches du clavier, …) Sélectionner dans ce panneau le ou les calques ą fusionner. La zone d’affichage présente le contenu du dernier calque sélectionné .

 

Pour ajouter un calque ą la sélection, cliquer avec la touche Maj

Pour ajouter/retirer un calque de la sélection, cliquer avec la touche  Cmd (  ). Cliquer/Glisser avec l’une ou l’autre touche pour ajouter/retirer une plage de calques

 

Sélectionner un groupe de calques

 

Le menu situé sous la liste permet de sélectionner un groupe de calques.

 

En choisissant « Tous » , on sélectionne tous les calques.

 

La suite du menu montre les groupes de calques détectés dans le document. En choisissant un de ces groupes, on sélectionne les calques qu’il contient. Les groupes de calques sont aussi appelés « Combinaisons de Calques » ou « Piles de Calques »

 

Le panneau Destination présente les options possibles :

 

-       A partir du n°:

 

            Introduire le numéro d’index auquel les Calques sélectionnés vont źtre importés.

 

-       Vérifier les Calques:

 

            En cochant cette option, on force la vérification de l’intégrité des Calques lors de l’insertion.

 

Cliquer sur le bouton « Insérer »

 

 

Les Calques réorganisés disparaissent de la liste

 

et s’ajoutent au Bureau des Calques.

 

  

 

La Vue courante est recalculée. On peut donc contrôler visuellement  l’ avancement de la réorganisation du Projet.

Toutes les opérations sont annulables. Pour annuler les insertions successives, cliquer sur le bouton « Annuler derniŹre Insertion »

 

Répéter le  processus d’insertion autant de fois que nécéssaire en choisissant ą nouveau des Calques dans la liste et en donnant  un nouvel index d’insertion .

 

Pour arrźter le processus de réorganisation, cliquer sur le bouton  « Fermer ».

Le processus d’insertion s’arrźte automatiquement quand la liste des calques est totalement vidée.

 

A la fin du processus, on retrouve en mémoire un projet totalement réorganisé.

 

Il est alors proposé d’enregistrer le projet réorganisé. Il est vivement conseillé de répondre positivement ą cette demande de sauvegarde.

 

NOTE :  Toutes les éléments du projet qui dépendent des Calques (POVs, Groupes, Combinaisons, Mises en Page, Robots) sont re-synchronisés sur les nouveaux numéros de calque.

 

 

 

 

 

Ouvrir Dossier#

 

 

16 – Ouverture des Dossiers Utiles

 

 

 

Le menu 3DTurbo X permet de demander l’ouverture des différents dossiers de support de 3D Turbo, sans avoir ą passer par le Finder :

 

-       Le Dossier  de Support           (Application Support/3DTurbo)

-       Le Dossier  BibliothŹque         (Habituellement difficile d’accŹs)

-       Le Dossier des Préférences

-       Le Dossier des Crash Logs     (DiagnosticReports)

-        

 

 

 

 

 

 

 

Envoyer les Crash Logs…#

 

 

17 – Envoi des Rapports d’Anomalie

 

 

 

Si des Rapports d’Anomalie (aussi appelés Crash Logs) sont détectés ą l’ouverture de 3D Turbo, le dialogue suivant est affiché :

 

 

Il permet de différer l’envoi ou d’envoyer les Rapports d’Anomalie au support technique d’Iluac de 2 maniŹres :

 

-       Automatiquement  par le bouton Envoyer les Rapports

-       Via le logiciel de Mail par le bouton Envoyer avec Infos, permettant l’ajout d’informations ou de piŹces jointes complémentaires, qui sont nécessaires ą Iluac pour étudier et reproduire les problŹmes.

-        

 

 

 

 

 

 

 

Quitter#

 

 

18 - Quitter

 

 

 

 

Pour quitter le logiciel, utiliser la rubrique Quitter du menu Fichier.

 

S’il est nécessaire d'enregistrer le travail en cours, le dialogue suivant est présenté :

 

 

Cliquer sur le bouton Oui pour enregistrer les modifications récentes apportées au document et non encore enregistrées sur disque.

Cliquer sur le bouton Non pour ignorer (et donc perdre) les modifications récentes apportées au document et non encore enregistrées sur disque.

 

Cliquer sur le bouton Annuler pour ne pas quitter le logiciel.


 

4 - Le CALEPIN

Le Calepin est un systŹme de prise de notes, mémorisation d’informations, de communication et de documentation associé ą 3D Turbo et au Projet/Document en cours de conception.

 

 

 

 

 

C’est un systŹme complet d’édition de texte augmenté de fonctionnalités particuliŹres telles que :  insertion d’images, liens Internet, Mail, Skype, liens d’activation de Points de Vue, évaluation de formules mathématiques (Calculette). C’est un véritable outil documentaire. Il est également utilisé pour produire certains rapports ( Vérification ou Correction du modŹle,… )



 

3-1 La FENśTRE du CALEPIN

Le Calepin est une fenźtre flottante de l’interface utilisateur de 3D Turbo.

La fenźtre du Calepin est redimensionnable pour s’intégrer de maniŹre non invasive parmi les fenźtres de l’interface de 3D Turbo, avec lesquelles elle s’auto-aligne.

 

 

Les Volets du Calepin

 

Le Calepin est doté de 2  volets indépendants :

 

-       Le volet Général, affecté ą 3D Turbo. Le contenu de ce volet est enregistré dans le domaine de 3D Turbo au moment de quitter et rechargé lorsque 3D Turbo est lancé.

 

-       Le volet Document, affecté au document en cours de création. Le contenu de ce volet est enregistré dans le fichier du Document, et rechargé ą l’ouverture du document. Chaque document contient donc son propre calepin.

 

Chaque volet peut néanmoins źtre enregistré séparément dans un fichier quelconque.

Les fichiers de Calepin peuvent źtre chargés ą tout moment et ajoutés ą la fin du volet affiché (Général ou Document)

 

Le volet Général est idéal pour mémoriser l’historique de travail, passer des consignes entre opérateurs, mémoriser des travaux ą faire, faire des commentaires ou consigner des idées, etc.

 

Le volet Document est idéal pour mémoriser l’historique de travail, pour expliquer la composition du document, et la structure des calques et des groupes, mémoriser et réactiver des Points de Vue, etc Il est stocké dans le document et le suit donc toute sa vie.  Si on ne souhaite pas que le calepin puisse źtre modifié, on peut le verrouiller.

 

Il n’y a aucune différence fonctionnelle entre les 2 volets qui sont donc dotés des mźmes fonctionnalités. La seule différence est donc l’usage de chaque volet, caractérisé par l’endroit oĚ il est enregistré. Chaque volet peut avoir sa propre couleur de fond pour le différentier d’un seul coup d’œil.

 

Toutes les fonctions sont  réalisées dans le volet affiché.

 

Dans la suite, on ne distinguera donc plus les volets et on parlera du Calepin en général .

La  Barre d’Edition de Style

 

La barre d’édition de Style permet de composer, affecter, visualiser et modifier les attributs graphiques d’un texte ou d’une sélection de texte. Elle s’utilise comme dans un traitement de texte classique.

Le Champ de Recherche

 

Le contrôle du champ de recherche permet d’indiquer la chaĒne de caractŹres ą rechercher dans le volet courant du calepin. Il fonctionne « au vol ». A chaque frappe de caractŹre une recherche est lancée. Une recherche répétitive est possible avec les touches « Retour » ou « Entrée »

 

 

Le Menu Contextuel  du Calepin

Le Calepin est sensible au clic contextuel (Clic droit ou Ctrl + Clic)

 

 

 

 

 

Son menu contextuel montré ci-dessus offre de nombreuses fonctions complémentaires au traitement de texte pur. Certains items de ce menu peuvent źtre désactivés selon l’état ou le contenu du Calepin.

 

3-2 FONCTIONS DU CALEPIN

 

 

 

 

 

Ouvrir / Fermer le Calepin#

 

1 – Ouvrir / Fermer le Calepin

 

 

 

Pour ouvrir ou  fermer le Calepin :

 

Cliquer dans l'icône .

ou

Utiliser le menu Outils/Calepin

 

On peut aussi fermer le Calepin en cliquant dans sa case de fermeture

 

 

 

 

 

 

 

 

2 – Redimensionner le Calepin

 

 

 

Pour changer les dimensions de la fenźtre du Calepin :

Cliquer dans le coin bas droit  et étirer la fenźtre

 

 

 

 

 

 

 

 

 

3 – Activer les Volets du Calepin

 

 

 

Pour changer le volet courant du calepin :

 

Cliquer dans le bouton correspondant au volet ą activer (Général ou Document).

 

 

Le bouton rempli de bleu indique le volet courant. De plus chaque volet peut avoir sa propre  couleur de fond permettant de la différentier.

 

 

 

 

 

 

 

 

4 –  Entrer et Styler le Texte

 

 

 

Pour entrer du texte :

 

            - Positionner le curseur ą l’endroit désiré dans le volet courant, soit en cliquant directement, soit en utilisant les touches flŹches du clavier  ć Ź é ź

 

-       Taper le texte.

 

Le texte prend le style courant.

 

La calepin est doté d’une barre de style :

 

 

Gras .          ABCDE

Italic            ABCDE

Souligné      ABCDE

Barré           ABCDE

Couleur du texte ou du fond de la fenźtre Déroule la palette de couleurs

Menu des Polices

Menu des hauteurs de texte

Forcer et appliquer le Style standard au point d’entrée ou ą la sélection

Appliquer le Style courant au point d’entrée ou ą la sélection.

 

Pour styler un texte :

 

-       Sélectionner le texte ą l’aide de la souris par cliquer/glisser ou en utilisant les touches flŹches du clavier ć Ź é ź en maintenant la touche Majuscule (ajout de caractŹre) ou la touche  ( ajout de mot entier) ou la touche  ( ajout de ligne).

 

-       La barre de style est mise ą jour avec le style de cette sélection

 

-       Changer les attributs désirés (graisse, couleur, taille, font,..) ą l’aide des boutons et menus décrits ci-dessus.

 

 

 

 

 

 

 

 

 

5 –  Insérer la Date ou l’Heure

 

 

 

 

Pour insérer la Date ou l’Heure :

 

-       Positionner le curseur ą l’endroit désiré dans le volet courant, soit en cliquant directement, soit en utilisant les touches flŹches du clavier  ć Ź é ź

 

-       Composer un style ą l’aide des boutons de la barre de Style.

 

-       Faire un clic droit pour dérouler le menu contextueL du calepin.

 

-        Choisir « Insérer la date » ou « Insérer l’heure ». La date ou l’heure sont insérées avec le style courant

 

 

 

 

 

 

 

 

6 –  Insérer une Image

 

 

 

Pour insérer une image :

 

-     Mettre l’image désirée dans le presse-papier par tout moyen adéquate (Copier, Photoshop, Preview, Capture d’écran,…)

 

-     Positionner le curseur ą l’endroit désiré dans le volet courant, soit en cliquant directement, soit en utilisant les touches flŹches du clavier  ć Ź é ź

-     Faire un clic droit pour dérouler le menu contextuel du calepin.

 

-      Choisir « Insérer l’image du Presse-Papier »

 

NOTA : on veillera ą ne pas insérer des images de grande taille, inadéquates pour le Calepin.

 

 

 

 

 

 

 

 

7 –  Insérer un Hyperlien

 

 

 

Un hyperlien est un style de texte enrichi d’informations complémentaires permettant d’effectuer des actions en cliquant simplement sur le texte.

 

Les hyperliens utilisables dans le Calepin sont :

 

• Les liens sur site Web

• Les liens d’envoi de Mail

• Les liens d’appel Skype ( systŹme de téléphonie gratuite par Internet)

• Les liens spéciaux d’appel des Points de Vue dans 3D Turbo, appelés HyperPOV

 

Pour affecter un hyperlien ą un texte :

 

-       Sélectionner le texte ą l’aide de la souris par cliquer-glisser ou en utilisant les touches flŹches du clavier ć Ź é ź en maintenant la touche Majuscule (ajout de caractŹre) ou la touche   ( ajout de mot entier) ou la touche  ( ajout de ligne).

 

-       Faire un clic droit pour dérouler le menu contextuel.

 

-        Choisir « Hyperlien sur la sélection» puis le type de lien

 

Un dialogue de renseignement est affiché :

 

Lien WEB :

 

Remplacer les … par une adresse de site internet : ex : http://turbo3d.online.fr et cliquer sur OK. Le texte sélectionné devient un lien Web :  Site

Lien MAIL:

 

Remplacer les …@… par une adresse eMail valide : ex turbo3d@online.fr

AprŹs « ?subject= » remplacer les … par le sujet du mail.

AprŹs « &body= » remplacer  …Message… par le texte du mail.

et cliquer sur OK. Le texte sélectionné devient un lien Mail:  Mail

 

Un exemple complŹtement renseigné :

mailto :turbo3d@online.fr ?subject=Demande d’info&body=Bonjour

 

Lien SKYPE :

 

Remplacer …SkypeID… par l’adresse SKYPE d’un correspondant et cliquer sur OK. Le texte sélectionné devient un lien Skype:  Appel Téléphone

 

NOTA : Pour activer ultérieurement ce type de lien, le programme gratuit SKYPE doit źtre installé sur la machine. Visiter le site web de SKYPE .

 

Lien Point de Vue

 

Remplacer … Nom du Point de Vue… par le nom souhaité pour le point de vue actuellement affiché dans 3D Turbo et cliquer sur OK. Le texte sélectionné devient un lien HyperPOV:  Vue Pers 3/4 faćade qui enregistre toutes les données nécessaires pour re-afficher la vue.

 

 

 

 

 

 

 

 

8 –  Effacer un Hyperlien

 

 

 

Pour effacer un hyperlien existant :

 

-       Sélectionner le texte ą l’aide de la souris par cliquer-glisser ou en utilisant les touches flŹches du clavier ć Ź é ź en maintenant la touche Majuscule (ajout de caractŹre) ou la touche   ( ajout de mot entier) ou la touche  ( ajout de ligne).

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

 

 Choisir « Hyperlien sur la sélection / Effacer »

 

 

 

 

 

 

 

 

9 –  Modifier un Hyperlien

 

 

 

Pour modifier un Hyperlien existant, procéder comme pour son insertion.

 

 

 

 

 

 

 

 

10 –  Insérer les Points de Vue

 

 

 

Pour insérer la liste des Points de Vue enregistrés de 3D Turbo :

 

-       Positionner le curseur ą l’endroit désiré dans le volet courant, soit en cliquant directement, soit en utilisant les touches flŹches du clavier  ć Ź é ź

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

 

-        Choisir « Insérer les Points de Vue »

 

Les dossiers et les Points de Vues isolés sont affichés dans le Calepin.

 

 

 

 

 

 

 

 

 

11 –  Activer un Hyperlien

 

 

 

Pour activer un Hyperlien :

 

Cliquer sur le lien.

 

Si le lien est du type Web, le navigateur Internet est activé pour visiter le site enregistré dans le lien.

Si le lien est du type Mail le logiciel de Mail est activé et un nouveau mail est automatiquement proposé, pré-renseigné avec les  informations enregistrées dans le lien.

Si le lien est du type SKYPE, le logiciel SKYPE est activé et un appel est lancé ą l’adresse du correspondant enregistré dans le lien.

Si le lien est du type HyperPOV, 3D Turbo active et visualise le point de vue correspondant (Groupe de calque ą visualiser, perspective ou vue plane, type de rendu, éclairages). Un lien  HyperPOV est strictement équivalent ą un Point de Vue enregistré

 

 

 

 

 

 

 

 

 

12 –  Calculatrice du Calepin

 

 

 

La calculatrice scientifique présente dans tous les champs numériques de 3D Turbo est également présente dans le Calepin.

Pour calculer une formule répondant ą la syntaxe générale de la calculatrice :

 

-       taper le texte de la formule dans le calepin (le style est indifférent)

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

 

-        Choisir «Evaluer la formule sélectionnée»

 

 

-      

 

Le résultat est automatiquement inséré ą la fin de la formule avec le signe =  et sélectionné. Si la syntaxe n’est pas correcte, un bip est émis.

 

 

On peut également définir simplement (et bien sěr utiliser) des variables :

 

 

 

 

 

 

 

 

 

13 –  Rechercher dans le Calepin

 

 

 

Pour rechercher une chaĒne de caractŹre dans le texte du calepin (volet courant) :

 

-       Positionner le curseur au dessus du champ de recherche pour qu’il acquiŹre le focus :

-       Entrer les caractŹres dans le champ de recherche

 

 

La recherche est effectuée immédiatement ą chaque frappe et le premier résultat s’il existe est sélectionné:


 

Pour sélectionner les autres résultats, positionner le curseur ą la fin de la chaĒne ą rechercher et appuyer sur la touche Retour. A chaque frappe, le résultat suivant est sélectionné :

 

 

 

 

 

 

 

 

 

 

14 –  Effacer le Calepin

 

 

 

Pour effacer le contenu du volet courant du calepin :

 

-       Tout sélectionner ( + A) et appuyer la touche « Suppr »

Ou

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

 

-       Choisir « Effacer»

 

 

 

 

 

 

 

 

15 –  Imprimer le Calepin

 

 

 

Pour imprimer le calepin (volet courant) :

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

 

-       Choisir « Imprimer»

 

 

 

 

 

                                                     

 

 

16 –  Enregistrer le Calepin

 

 

 

Pour enregistrer le Calepin (volet courant) dans un fichier :

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

 

-       Choisir « Enregistrer sous…»

 

Répondre aux dialogues du systŹme invitant ą donner le nom du fichier calepin et  son emplacement. L’extension d’un fichier calepin est .nbook. L’icône d’un fichier Calepin est :

 

En double cliquant sur un fichier de Calepin on démarre 3D Turbo, ou, s’il est déją actif, 3D Turbo lit le calepin et l’ajoute ą la fin du volet courant.

 

 

 

 

 

 

 

 

 

17 –  Ouvrir un Calepin

 

 

 

Pour ouvrir un fichier Calepin et ajouter son contenu ą la fin du volet courant :

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

 

-       Choisir « Ouvrir »

 

ou

            Double cliquer sur l’icône d’un fichier .nbook

 

 

 

 

 

                                                     

 

 

18 –  Verrouiller un Calepin

 

 

 

Pour verrouiller le volet courant du calepin :

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

-    Choisir « Verrouiller »

 

Lorsqu’un volet est verrouillé, il ne peut plus źtre modifié, mais il peut toujours źtre imprimé et enregistré. La barre de style est grisée.

 

Tout tentative de frappe de texte produit le message :

 

     

 

Il est toutefois toujours possible de cliquer sur les hyperliens de type POV pour activer des Points de Vue. NOTE : Les hyperliens WEB, Mail et Skype ne sont pas actifs en mode verrouillé. Seuls les HyperPOV sont accessibles.

 

 

 

 

 

 

 

 

19 –  Déverrouiller un Calepin

 

 

 

Pour déverrouiller le volet courant du calepin :

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

 

-    Choisir « Déverrouiller» dans le menu dynamique (touche alt)

 

 

 

 

 

 

 

 

20 –  Correcteur Orthographique

 

 

 

Le Calepin est doté d’un correcteur orthographique qui permet de :

 

      Vérifier globalement l’orthographe

      Vérifier l’orthographe pendant la frappe de texte

      Corriger les mots mal orthographiés.

 

Vérifier globalement l’orthographe :

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

-       Choisir « Orthographe / Vérifier l’orthographe»

 

Les mots mal orthographiés sont soulignés en rouge :

 

 

Vérifier globalement l’orthographe  pendant la frappe :

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

-       Choisir « Orthographe / Vérifier l’orthographe lors de la frappe»

 

L’orthographe de chaque mot est vérifiée immédiatement lors de la frappe.

 

Corriger les mots mal orthographiés :

 

-       Faire un clic droit pour dérouler le menu contextuel du calepin.

-       Choisir « Correcteur»

 

La fenźtre du correcteur s’affiche :

 

 

Pour naviguer dans les erreurs d’orthographe, cliquer dans le bouton :

 

Pour corriger l’erreur affichée, cliquer dans le bouton :

AprŹs usage, fermer la fenźtre du correcteur en cliquant dans sa case de fermeture.

ATTENTION: Veillez ą ce que le Calepin ait toujours le focus pendant la correction orthographique. Le Calepin perd le focus quand le curseur passe au-dessus de la fenźtre de travail. Le Calepin acquiert le focus quand le curseur passe au-dessus de sa fenźtre.

 

 

 

 

 

 Vectorisation de texte#  texte 3D#  Conversion de Texte#

 

 

21 –  Vectoriser la Sélection

 

 

 

Les fonctions de Texte du calepin  ( Fonte et taille ) sont utilisées pour générer des textes en 3D.  Les textes sont affichés ą l’aide de Glyphes. Les Glyphes sont les définitions géométriques de chaque lettre. Pour un mźme signe ( lettre, chiffre, ponctuation,…) les glyphes diffŹrent selon la police de caractŹre (Fonte) et la hauteur utilisée.  La vectorisation de texte consiste ą transférer dans un calque les glyphes d’un bloc de texte sélectionné.

Réglages de la Vectorisation de Texte

Pour régler les options de vectorisation de texte, dérouler le menu contextuel du calepin en appuyant sur la touche Option ( alt   ) et choisir Options de Vectorisation.

 

 

Précision de vectorisation

 

 Les courbes définissant les glyphes sont vectorisées avec plus ou moins de précision :

Fine :         5 points par segment de courbe

Moyenne : 3 points par segment de courbe

Faible :       les Pôles des courbes sont les points.

 

Facettisation des glyphes vectorisés

 

La surface intérieure des glyphes peut źtre convertie en facettes si l’option Avec Facettes est cochée.

 

Vectorisation de Texte

Pour vectoriser un bloc de texte multi fontes et multi hauteurs :

 

-  Sélectionner le bloc de texte.

- Dérouler le menu contextuel du calepin en appuyant et choisir Vectoriser la Sélection.

 

Le texte sélectionné est converti dans le calque courant, dans le plan de la vue courante, le coin haut gauche du Calepin étant considéré comme le point (0,0) de l’espace, 0,35 unité de modélisation valant 1 point pica. Ainsi, la mise en page du bloc et les hauteurs respectives des caractŹres de texte sont respectées par la conversion.

 

 

Les polices spéciales contenant des figures peuvent aussi źtre utilisées :

 

 

 

5 - Mesure des temps de travail

3D Turbo comptabilise les temps de travail effectué sur un document. Le temps est compté uniquement lorsque 3D Turbo est actif. Lorsque 3D Turbo est en arriŹre plan, le compteur est mis ą l’arrźt. Le comptage reprend quand 3D Turbo redevient actif.

 

Le compteur de temps est remis ą zéro lorsqu’on ouvre un document, ou lorsqu’on commence un nouveau document ou que l’on enregistre ou enregistre sous…

 

Les sessions

 

La mesure des temps de travail est décomposée en sessions.

 

Une session commence lorsqu’on ouvre un document, ou que l’on commence un nouveau document ( Menu Fichier / Nouveau ), ou aprŹs un Enregistrer ou Enregistrer-sous…

 

Une session se termine lorsqu’on Enregistre ou Enregistre-sous… le document.

 

Une session est suspendue lorsque 3D Turbo passe en arriŹre-plan

 

Les sessions sont enregistrées dans le document de maniŹre cumulative.

 

Ainsi l’historique du travail effectué sur un document est conservé avec le document.

 

Exporter les Statistiques

 

Pour exporter en format tableur le contenu des sessions :

 

-       Utiliser le menu «Fichier / Exporter les Statistiques »

 

Si aucun document n’est ouvert ą ce moment-lą, le message suivant est délivré dans le volet « document » du calepin et dans le presse-papier :

 

Aucune session n’a encore été enregistrée.

3D Turbo fonctionne depuis …date… …heure… (…durée…)

Pour remettre le compteur de temps ą Zéro, utiliser le menu “Fichier/Nouveau”

 

Si un document est ouvert ą ce moment-lą,  le nom du  fichier et son  emplacement son demandés ą l’opérateur :

 

 

Les statistiques ( = la liste des sessions de travail ) sont enregistrées dans un fichier  .txt en format tableur :

 

 

Copier les Statistiques

Pour copier les Statistiques dans le presse-papier et dans le volet Document du Calepin :

 

-         Utiliser le menu dynamique  «Fichier / Copier les Statistiques » (touche alt)

 

Effacer les Statistiques

Pour effacer les Statistiques d’un Document ouvert :

 

-       Utiliser le menu dynamique  «Fichier / Effacer les Statistiques » (touche ctrl)

-       Enregistrer le document.